Issues with the Storage Service
Resolved
Nov 29 at 05:36am UTC
We have received confirmation from the vendor that the issue has now been resolved. Storage service should now be fully functional; we thank you for your patience and apologize for any inconvenience caused.
Affected services
Storage
Updated
Nov 29 at 05:23am UTC
We received another update from the vendor that the fix for the issue is being rolled out and we should start to see improvements soon
Affected services
Storage
Updated
Nov 29 at 03:58am UTC
Our vendor has alerted us that they are continuing to work on the problem and bring services back online. Our team is currently working to aid them with this. We will keep posting updates as we work on the issue.
Affected services
Storage
Updated
Nov 29 at 02:48am UTC
The vendor has updated us that the issue is being worked on as a top priority, and more updates will be shared shortly.
Affected services
Storage
Created
Nov 29 at 02:03am UTC
We have noticed degraded performance in our storage API due to issues with our storage provider. We are working with the vendor to address this as quickly as possible. We will share more updates shortly.
Affected services
Storage