Back to overview
Degraded
Uploads stuck at pending
May 15 at 05:37pm UTC
Affected services
Storage
Storage
Storage
Resolved
May 16 at 11:09pm UTC
We have fixed the issue. Thank you for your patience.
Affected services
Storage
Storage
Storage
Updated
May 15 at 07:46pm UTC
We are currently reverting the change that caused the issue.
Affected services
Storage
Storage
Storage
Updated
May 15 at 06:14pm UTC
We are still investigating the issue.
Affected services
Storage
Storage
Storage
Created
May 15 at 05:37pm UTC
We are investigating an issue where file uploads greater than 5MB are stuck at pending. We'll update as we find more.
Affected services
Storage