Back to overview
Degraded

Service Degradation in the Storage API

Jun 26 at 02:12pm UTC
Affected services
Storage

Resolved
Jun 26 at 08:53pm UTC

Storage service has stabilized.

Created
Jun 26 at 02:12pm UTC

We are investigating an issue with the Storage API arising out of issues with the downstream Cloud provider.