Null relationship attributes
Resolved
Aug 27 at 02:30pm UTC
We have released the fix.
Affected services
Updated
Aug 27 at 01:59pm UTC
We have found a fix for an edge case and will be releasing it soon.
Affected services
Updated
Aug 27 at 10:42am UTC
Closing this incident as the applied fixes have improved service performance.
Affected services
Updated
Aug 27 at 06:56am UTC
We have released a few fixes and are currently monitoring for issues.
Affected services
Updated
Aug 27 at 12:22am UTC
We had to make some tweaks and will need to go through another round of testing and reviews. Thank you for your patience.
Affected services
Updated
Aug 26 at 09:01pm UTC
We are testing and reviewing a patch now.
Affected services
Updated
Aug 26 at 07:48pm UTC
We've narrowed down the issue and are in progress with a patch.
Affected services
Created
Aug 26 at 05:12pm UTC
As of 1.8, relationship attributes must explicitly be requested. However, apps using a 1.7 SDK should still have the same behavior where the relationship attributes automatically resolved 3 levels deep. We're investigating why this backwards compatibility is not working.
A workaround right now is to update to the latest SDK and select the related attributes.
See https://appwrite.io/docs/products/databases/relationships#performance-loading for more info.
Affected services