Back to overview
Degraded

Usage display

Sep 02 at 07:36am UTC
Affected services
Console
Console
Console
Console

Resolved
Sep 02 at 11:59am UTC

The usage aggregation has been completed, usage display is now showing the correct values.

Created
Sep 02 at 07:36am UTC

We’ve rolled out a new UI for usage and billing. While background aggregation is completing, some values in the UI may appear temporarily inconsistent (for example, project vs. team usage or pricing details).

This adjustment period may last 1–2 hours. No resources or services are impacted - this is a display-only issue, and all usage is being tracked correctly in the backend.

We’ll update this notice once aggregation is complete.