Back to overview
Degraded

Degraded email delivery

Feb 25 at 12:49am UTC
Affected services
Auth
Auth
Auth
Auth
Auth
Auth

Updated
Feb 25 at 07:28pm UTC

We have checked things on our end and with our email provider, but everything looks okay. We have reached out to MIcrosoft for guidance.

Created
Feb 25 at 12:49am UTC

We are experiencing degraded delivery of emails to Microsoft email addresses (e.g. outlook.com, hotmail.com). You may want to use your own custom SMTP server to mitigate this issue.