Degraded email delivery
Resolved
Mar 27, 2026 at 08:07am UTC
We have migrated to a fallback provider, and service is now fully restored. We will continue to monitor the situation closely and work with our vendors to help prevent similar incidents in the future.
Affected services
Updated
Mar 27, 2026 at 06:37am UTC
We are continuing to work with our SMTP provider to resolve this issue. At the same time, we are evaluating a migration to a fallback provider to help accelerate a resolution.
We apologize for the inconvenience and appreciate your patience while we work to resolve this issue.
Affected services
Created
Mar 26, 2026 at 11:38pm UTC
We are working with our vendor to resolve email delivery issues. For the time being, it would be best to use a custom SMTP server if you can.
Affected services