Elevated errors on NYC region
Resolved
May 20, 2026 at 1:48am UTC
Our upstream cloud infrastructure vendor has confirmed that the issue has been resolved. From our side, we can confirm that all affected services are now fully operational and available again.
We will continue working closely with the vendor to complete a full investigation into the incident, better understand the root cause, and identify additional measures that can help prevent similar issues in the future. We appreciate everyone’s patience while this incident was being addressed.
Affected services
Updated
May 20, 2026 at 12:42am UTC
Our upstream cloud infrastructure vendor has acknowledged the incident and confirmed that they are actively investigating the issue. According to their latest update, engineering teams have been engaged and are currently working to identify the root cause and restore the affected infrastructure components as quickly as possible. We are maintaining close communication with their team and will continue to provide updates as more information becomes available.
Affected services
Updated
May 20, 2026 at 12:36am UTC
We’ve detected a failure in our upstream cloud infrastructure. We’ve contacted our vendor and requested urgent assistance to recover the affected components.
Affected services
Created
May 19, 2026 at 11:52pm UTC
We're noticing an elevated amount of errors and increase in response time from NYC region. Our team is investigating the issue.
Affected services