Back to overview
Degraded

Elevated errors on FRA region

Jun 11, 2026 at 2:38pm UTC
Affected services
API
Auth
Databases
Storage
Messaging

Resolved
Jun 11, 2026 at 4:06pm UTC

All services are fully available for all customers. Our team will share an incident report in the the next few days with actions items we will take to prevent such incidents happening again. Thank you for you support and patience.

Updated
Jun 11, 2026 at 3:07pm UTC

We applied some fixes to isolate and mitigate the issues for some users. We're now validating recovery.

Created
Jun 11, 2026 at 2:38pm UTC

Internal monitoring has alerted the team about elevated errors rates on the FRA region for a subset of projects. We're investigating the issue.