Back to overview
Downtime

Cloud is down

Mar 11 at 10:06am UTC
Affected services
API

Resolved
Mar 11 at 10:24am UTC

All services have been restored. The team will continue to monitor the system.

Updated
Mar 11 at 10:22am UTC

We've identified the issue and the fix is underway.

Created
Mar 11 at 10:06am UTC

The team is investigating the issue.