Back to overview
Degraded
Instability with FRA sites and functions
Mar 20, 2026 at 07:48pm UTC
Affected services
Functions
Sites
Resolved
Mar 20, 2026 at 09:05pm UTC
Services have restored. Thanks for your patience
Affected services
Created
Mar 20, 2026 at 07:48pm UTC
We're investigating issues with FRA sites and functions
Affected services